Accenti in LaTeX

Area riservata al e al suo impiego per scrivere le formule
Stardust
Messaggi: 279
Iscritto il: 12 set 2009, 20:48

Accenti in LaTeX

Messaggio da Stardust » 15 apr 2010, 15:05

Nel linguaggio LaTeX le lettere accentate vanno scritte con un apposito comando, del tipo \'{e}=é.
L'uso del corretto apostrofo è essenziale per ottenere gli accenti gravi ed acuti, ma ho notato che sulla mia tastiera (per Win XP) manca quella specie di apostrofo "storto"
necessario per ottenere, per esempio, "è".
Ciò comporta un po' di problemi linguistici su cui si può anche sorvolare in documenti ad uso personale, ma che diventano fastidiosi per lavori più importanti.
Esiste una soluzione a questo piccolo inconveniente?
In nature we do not find past, present and future as we recognise them, but an evolutionary process of change - energy never trapped for too long - life always becoming.
(Taken and modified from Lighthousekeeping by J. Winterson)

Senior
Messaggi: 22
Iscritto il: 11 gen 2009, 15:28

Re: Accenti in LaTeX

Messaggio da Senior » 15 apr 2010, 16:15

Allego un'immagine che penso possa essere utile.
Allegati
Tabella accenti.jpg
Tabella accenti.jpg (55.76 KiB) Visto 5931 volte

.mg
Messaggi: 42
Iscritto il: 7 mar 2010, 18:04

Re: Accenti in LaTeX

Messaggio da .mg » 15 apr 2010, 17:11

Stardust ha scritto:Esiste una soluzione a questo piccolo inconveniente?
Certo, basta usare la codifica UTF8 (e caricare il pacchetto inputenc con l'opzione utf8 in questo caso)

Avatar utente
dl.censi
Amministratore
Messaggi: 175
Iscritto il: 6 gen 2009, 16:42
Contatta:

Re: Accenti in LaTeX

Messaggio da dl.censi » 15 apr 2010, 21:45

Stardust ha scritto:che sulla mia tastiera (per Win XP) manca quella specie di apostrofo "storto"
necessario per ottenere, per esempio, "è".
[...]
Esiste una soluzione a questo piccolo inconveniente?
tasto ALT + il numero 96 (sul tastierino numerico)

Ippo
Messaggi: 529
Iscritto il: 28 gen 2009, 16:16
Località: Pisa - Belluno

Re: Accenti in LaTeX

Messaggio da Ippo » 15 apr 2010, 23:57

.mg ha scritto:
Stardust ha scritto:Esiste una soluzione a questo piccolo inconveniente?
Certo, basta usare la codifica UTF8 (e caricare il pacchetto inputenc con l'opzione utf8 in questo caso)
Questo in effetti è la via.

Codice: Seleziona tutto

\usepackage[utf8]{inputenc}
a inizio documento. Le vocali accentate vengono riprodotte normalmente.

Stardust
Messaggi: 279
Iscritto il: 12 set 2009, 20:48

Re: Accenti in LaTeX

Messaggio da Stardust » 17 apr 2010, 16:06

Premetto che è la prima volta che aggiungo un package al MikTeX 2.8 che uso (attraverso il software LaTeX Editor), quindi sono alquanto inesperto.
Una volta downloadato dal sito del CTAN il pacchetto inputenc, dopo aver decompresso la sua cartella, sono rimasto un po' stupito nel vedere all'interno numerosi file .ERR e .EL (che il mio computer non è in grado di leggere) e nessun file eseguibile, tipo .exe.
Comunque devo aggiungere l'intera cartella all'interno di quella dove è il resto di MikTeX, o no? E' indifferente la posizione in cui la metto, oppure ha una sua sottocartella specifica?
Grazie a tutti.
In nature we do not find past, present and future as we recognise them, but an evolutionary process of change - energy never trapped for too long - life always becoming.
(Taken and modified from Lighthousekeeping by J. Winterson)

.mg
Messaggi: 42
Iscritto il: 7 mar 2010, 18:04

Re: Accenti in LaTeX

Messaggio da .mg » 17 apr 2010, 16:25

Non uso WIndows e non so risponderti nello specifico, però inputenc dovrebbe essere presente di default in MikTeX, non devi scaricare nient'altro da Internet una volta che hai tutta la distribuzione funzionante sul tuo computer

Stardust
Messaggi: 279
Iscritto il: 12 set 2009, 20:48

Re: Accenti in LaTeX

Messaggio da Stardust » 17 apr 2010, 22:01

Se c'è, dovrebbe funzionare... Così ho provato a compilare un brevissimo documento LaTeX con le vocali accentate tipiche delle comuni tastiere europee.
Purtroppo qualcosa è andato storto, perchè ricevo il seguente messaggio di errore:

Codice: Seleziona tutto

! Package inputenc Error: Unicode char \u8:ì,è not set up for use with LaTeX.
See the inputenc package documentation for explaination. 
Type H <return> for immediate help.
  . . .
1.5 ì, è
           ,é, ò, à, ù
?
Ho usato il comando spiegato in uno dei post precedenti da Ippo, ma non riesco a capire se l'errore è dovuto all'assenza del pacchetto oppure al modo sbagliato/incompleto di impostare la codifica UTF8.
Per usare quest'ultima basta inserire

Codice: Seleziona tutto

...[utf8]...
nel comando oppure bisogna agire su qualche parametro prima di procedere così?
In nature we do not find past, present and future as we recognise them, but an evolutionary process of change - energy never trapped for too long - life always becoming.
(Taken and modified from Lighthousekeeping by J. Winterson)

.mg
Messaggi: 42
Iscritto il: 7 mar 2010, 18:04

Re: Accenti in LaTeX

Messaggio da .mg » 18 apr 2010, 14:40

Se non posti il codice che hai usato posso solo andare a intuito per capire cosa hai fatto (la parte fondamentale è il preambolo, cioè tutto ciò che c'è prima di `\begin{document}').
Comunque, compilando il seguente documento

Codice: Seleziona tutto

\documentclass{article}

\usepackage[utf8]{inputenc}

\begin{document}
àèìòù
\end{document}
ma salvato con codifica ISO-8859-1 ottengo questo errore

Codice: Seleziona tutto

./main.tex:6: Package inputenc Error: Unicode char \u8:��� not set up for use w
ith LaTeX.

See the inputenc package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.6 ��
       �
? 
e mi sembra abbastanza simile al tuo. Salvando il documento con codifica UTF-8 invece viene compilato correttamente e le lettere accentate compaiono normalmente. Deduco quindi che devi modificare la codifica con cui hai salvato il file

Stardust
Messaggi: 279
Iscritto il: 12 set 2009, 20:48

Re: Accenti in LaTeX

Messaggio da Stardust » 18 apr 2010, 17:25

Esattamente: ho creato il documento proprio così, a parte le virgole.
Evidentemente il problema sta nel salvare il documento con la corretta codifica.
Ho guardato nelle impostazioni di LaTeX Editor (Configurazione/Opzioni, e altre) senza successo, nè tantomeno ho trovato qualcosa di utile in MiKTeX 2.8/Maintenance/Settings, che dal nome dovrebbe essere il luogo dove mettere le mani per queste modifiche...
Come si può agire per impostare il salvataggio con codifica UTF8?
In nature we do not find past, present and future as we recognise them, but an evolutionary process of change - energy never trapped for too long - life always becoming.
(Taken and modified from Lighthousekeeping by J. Winterson)

Rispondi